Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Amazon SES ends support for 'Signature V3' - Update Sendy to the latest version
  • Vote Up0Vote Down BenBen
    Posts: 3,678Sendy support

    Amazon is ending support for Amazon SES API requests signed with 'Signature Version 3' on September 30, 2020 in favor of the new 'Signature Version 4'.

    Sendy uses 'Signature Version 4' in Sendy version 4.0.4 onwards:

    What you need to do

    Update to the latest version of Sendy (https://sendy.co/get-updated) by September 30, 2020 if you're on a version of Sendy that's older than 4.0.4.

    The following is an email you may have received from Amazon:


    Amazon Web Services currently supports Amazon SES API requests that are signed using Signature Version 3 and Signature Version 4 processes. Signature Version 4 further enhances the security around authentication and authorization of Amazon SES customers by using a signing key instead of your secret access key. To improve the security for our customers, beginning October 1, 2020, Amazon Signature Version 3 will be turned off (deprecated) in Amazon SES in favor of Signature Version 4.

    Amazon SES customers who are still using Signature Version 3 must migrate to Signature Version 4 by September 30, 2020. After that, Amazon SES will only accept requests that are signed using Signature Version 4. For more information, see Signature Version 4 signing process [1].

    What Happens if I Don't Make Updates?

    Requests signed with Signature Version 3 that are made after September 30, 2020 will fail to authenticate with Amazon SES. Requesters will see errors stating that the request must be signed with Signature Version 4.

This discussion has been closed.
All Discussions