Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Everything seems OK, but no emails get sent.
  • So, i installed Sendy under Media Temple Grid Service.
    Everything went fine. I also entered my Amazon credentials (SES already had production access), verified the addresses (plus the domains), setup DKIM, SPF, SenderID authentication etc...
    Cron task is already set.
    Created a list, created a campaign and then i sent a test email message. I got the email just fine. Authenticated and so on. Great.

    Then i tried to send the campaign to the whole list (it's just a test staging list for now with only 5 addresses).
    Pending showed up until the cron task kicked in. Great. Quota of SES reflected the changes after the campaign was sent. I also got the email saying the campaing was successfully sent.

    There was only a "slight" problem... I got absolutetly no email to those 5 addresses on the list.
    The only error i got from PHP was that CURLOPT_FOLLOWLOCATION was not available because of the open_base dir (safe mode is of course off)

    I can't figure out what might be wrong. Any ideas?
  • 10 Comments
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    Hi, thanks for the details. Do you mean your Amazon SES quota reflects the number of emails sent but you receive no emails?
  • Exactly... Also, if send a test email directly from SES console to the same email addresses as on that staging list, they are delivered with no problems. :/
  • I should mention too that i tried deleting the AWS credentials and try to send the campaign through the local mail server.
    Mails got delivered just fine.
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    That is weird because if SES reflects the number of emails sent, that means the emails are sent. Have you checked if they ended up in your spam folders?

    I'm trying to check the error message that you receive. Can you check this link to see if you do anything to eliminate the error? http://kb.mediatemple.net/questions/514/How+do+I+set+the+path+for+open_basedir?#gs
  • I believe that error has to do with open_basedir and/or safe mode being enabled... Even if i change open_basedir to something else, i'll still get that error cause curl doesn't allow the followlocation option if one of those are enabled.

    But still i'm gonna give it a go and see. What extra path should i give to open_basedir? The path containing sendy installation?
  • OK, I included the sendy installation path to open_basedir and still got the following errors:

    PHP Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /absolute_path_of_sendy_install/includes/helpers/ses.php on line 481
    PHP Notice: date_default_timezone_set(): Timezone ID '' is invalid in /absolute_path_of_sendy_install/app.php on line 47

    Also i noticed that even if the SES quota changes (still can't get the emails to those addresses, and no there are not in their spam folders) the changes are unsually slow... With only 3 receipients for example it has counted only one as of now...
  • I'm at a loss :( Can't figure out why this is happening. I disabled open_basedir option completely, i changed the timezone (in case that was the cause) ....Still, SES Quota (kinda) changes, but emails don't get delivered.
  • I have a similar problem. What's weird is the Amazon SES "sent in 24 hours" number goes up by the number of mailings I've sent, but not by the number of emails sent. Or at least that's what it FEELS like is happening.
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    @Mallinanga

    Please PM me your installation URL, email and password. As well as your FTP and hosting control panel's credentials so that I can check your database.

    Thanks.
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    Hi Mallinanga, I've found the issue.

    For some reason, the new 'queue' table required for the latest version was not created in your database. I've manually ran 'create table' query in PHPmyAdmin and you should be able to send emails now!

    I discovered this while troubleshooting for @jaredscottm and verified that emails were sent after the 'queue' table was created.
This discussion has been closed.
All Discussions