Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

eMails not being delivered...
  • Vote Up0Vote Down SandeepSandeep
    Posts: 18Sendy user
    I have recently updated to 1.1.1.2 ... campaign showing all emails sent but none of them being deliver... (this was a test campaign)

    checked with amazon console as well and it says 5 eMails sent... )=


    here is errorlog:
    [20-Nov-2012 13:53:31] PHP Warning: array_unique() [function.array-unique]: The argument should be an array in /home/sonume/public_html/ses/report.php on line 651
    [20-Nov-2012 13:56:28] PHP Warning: array_unique() [function.array-unique]: The argument should be an array in /home/sonume/public_html/ses/report.php on line 651
    [20-Nov-2012 13:56:41] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
    [20-Nov-2012 11:57:13] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
    [20-Nov-2012 11:58:08] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
    [20-Nov-2012 12:14:43] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
    [20-Nov-2012 12:20:25] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
    [20-Nov-2012 12:20:27] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
  • 14 Comments
  • Vote Up0Vote Down SandeepSandeep
    Posts: 18Sendy user
    tested again... just to make sure but nope still same ... eMails are not being delivered... receiving confirmation email saying email sent though ... \-:

    further error log:
    [20-Nov-2012 12:34:14] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
    [20-Nov-2012 12:34:16] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
    [20-Nov-2012 12:34:43] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
    [20-Nov-2012 12:34:47] PHP Warning: Division by zero in /home/sonume/public_html/ses/app.php on line 120
    [20-Nov-2012 14:43:24] PHP Warning: array_unique() [function.array-unique]: The argument should be an array in /home/sonume/public_html/ses/report.php on line 651
  • @Sandeep where is your error log saved? I experience the same issue but my error log doesn't show anything worth noting in the mail sandy directory :\
  • Vote Up0Vote Down SandeepSandeep
    Posts: 18Sendy user
    @jaredscottm I have it on installed directory ...

    /public_html/Your-Installation-Directory/error_log to be exact...

  • @Sandeep yeah, I don't even get errors with my similar symptom. Just waiting on @Ben to login and poke around
  • same here?
  • strange even if i go back to an older version which deliver email before they are not delivered anymore!
  • This appears to be a bug. When the campaign is created and before it is sent, the Sent field in the Campaigns table is Null. After the send button is pushed, the Sent field contains 1353459337, which is most likely a lot larger than the To Send field. The program is comparing Sent to To Send and concluding it's done when it hasn't sent anything. Should be an easy fix as soon as a developer gets a look at it.
  • @Sandeep

    After several hours of checking an tweaking around, check if the FROM email and Reply email under the Brand settings is a valid email address.

  • Vote Up0Vote Down SandeepSandeep
    Posts: 18Sendy user
    @john_sbwg humm! I also think this is just a bug... Hope your point help @Ben to find out error much easier now (=
  • Vote Up0Vote Down SandeepSandeep
    Posts: 18Sendy user
    @sky_fall I double checked it is correct and match with my SES Console...

    @john_sbwg if it is a script side problem then.. any idea why on my SES Console also decreasing counts? I'm kinda confused here lol... ((=
  • @Sandeep: My count on the SES console has gone up to 7 from 5. I can't tell if each campaign sent one email. It's a matter of when the huge number is being written to the database table. If it's written after the first email is sent, then it makes sense that my count would go up one each time. I don't know the code well enough to track it down easily.
  • @Sandeep: the original 5 count was from test emails, btw. Apparently, this problem only exists when sending to a list. Test emails work just fine.
  • Vote Up0Vote Down SandeepSandeep
    Posts: 18Sendy user
    @john_sbwg ok! get it! I did bunch of test emails! Now waiting @Ben if he get some time from @Batman lol ((=
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    Hey guys, the problem has been found.

    For some reason, the new 'queue' table required for the latest version was not created in the database for some users. I've released 1.1.1.3 to fix this.

    Download the new build at http://sendy.co/get-updated. If you're on 1.1.1.2, just replace /includes/update.php.
This discussion has been closed.
All Discussions