Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

404 when trying to install. Have tried everything I can find.
  • OK, I have to admit it. I'm out of moves. Sorry. I've read over a dozen threads on this, and I know it's covered extensively here.

    I'm visiting rwpbiz.com/sendy and getting a 404.

    I'm on Bluehost. Have confirmed mod_rewrite is enabled.

    Everything is uploaded straight to rwpbiz.com. There are not any other .htaccess files or alternate installations on this domain. The only thing installed here is Sendy.

    I've set up /includes/config.php.

    I've added both RewriteBase / and RewriteBase /sendy to .htaccess

    When I try to visit http://rwpbiz.com/_compatibility.php?i=1, I get a 404 also.

    This is the most recent version of Sendy. I've just purchased and downloaded this week.

    It's my pleasure to send ftp credentials or anything necessary. Any insight is much appreciated!

  • 5 Comments
  • Vote Up0Vote Down BenBen
    Posts: 3,537Sendy support

    Hi,

    Restore Sendy's .htaccess file to the original. Then just add RewriteBase / after the line RewriteEngine On.

    Then visit rwpbiz.com to install, not rwpbiz.com/sendy.

    Your APP_PATH in /includes/config.php should be 'http://rwpbiz.com'.

    Best regards,
    Ben

  • Thank you Ben. I've restored htaccess to original. I added RewriteBase /. My APP_PATH was already 'http://rwpbiz.com', so I left that alone. When I visit rwpbiz.com, all I get is a blank page.

  • What should I check next? My config.php is currently set as follows:

        /*  Set the URL to your Sendy installation (without the trailing slash) */
    define('APP_PATH', 'http://rwpbiz.com');
    
    /*  MySQL database connection credentials  */
    $dbHost = 'localhost';
    $dbUser = 'xxx';
    $dbPass = 'xxx';
    $dbName = 'xxx';
    

    My htaccess is currently set as follows:

        RewriteEngine On
        RewriteBase /
        RewriteCond %{SCRIPT_FILENAME} !-d
        RewriteCond %{SCRIPT_FILENAME} !-f
        RewriteRule ^([a-zA-Z0-9-]+)$ $1.php [L]
    

    These are the only edits I've made. I had originally uploaded this to a domain other than what I had registered upon purchase. Geesh :) But I changed that, and the change has been approved. All the same issues still persist.

    What am I missing?

  • Vote Up0Vote Down BenBen
    Posts: 3,537Sendy support

    Hi,

    I visited http://rwpbiz.com and it successfully redirected me to the installation page http://rwpbiz.com/_install.php. Is that not the same for you?

    Best regards,
    Ben

  • Thanks so much for the follow up Ben. Really appreciate that. I checked the site all the way til about 1AM last night, but the screen was just blank. No error. Just a blank white screen. I tried clearing browser cache. I tried alternate browser.

    Shows up fine for me this morning. I'm a little at a loss here, but I see the install screen now! Perhaps it was a weird caching issue or something. No idea. Rock on :)

    Thanks again sir.

This discussion has been closed.
All Discussions