Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Sendy Doesn't Get Past Login Screen on New GoDaddy Account
  • I've been emailing back and forth with Ben already on this but thought I would drop it here to see if anybody else had a similar issue.

    My company recently switched from NameCheap.com to GoDaddy.com for hosting. We had Sendy setup and running great on Namecheap.

    Once we transferred our domains over, I migrated our existing Sendy database and installation over to the new server. I updated the config file to connect to the new database, the app path stayed the same.

    Initially, when I browsed my sendy app path, the site would redirect to the root index.html file. So if I go to foo.com/sendy, I was taken to foo.com

    I added a mode rewrite directive in the .htaccess file (RewriteBase /sendy) and that helped me load the login form. Initially logging just didn't work and neither did the forgot password process. They just reloaded to the login form.

    Ben looked at the files, setting, and database and felt it was all good. He suggested I run an upgrade, which I did. Once I did that the forgot password works, but nothing else changed.

    Today, I setup a fresh database and did a fresh install of Sendy into a new directory under my same domain. Install runs fine, I'm taken to the login page, I login, and the login form just reloads again. And again I had to add the RewriteBase directive as well.

    So my existing install that worked on NameCheap fails on GoDaddy as does a fresh install.

    GoDaddy support says that mod_rewrite is turned on on my shared server. They looked at the code, but beyond that they have no idea what the issue us. I am assuming there is some redirect related setting that needs to be made on the domain, or a cname entry that we are missing. Has anybody else run into this and if so how did you handle it. I'm having to manually send bulk emails with a script and it is SLOW, bad practice and gets me no info. I need my Sendy back.

    TIA!

  • 4 Comments
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support

    Hi @ccmwebmaster,

    I've went through great lengths to troubleshoot this issue and finally nailed down to this → session variables.

    Long story short, I created a simple script to test if session variables are working in your PHP and it's not.

    This is the script:

    <?php session_start(); $_SESSION['company'] = 'Sendy'; echo $_SESSION['company']; ?>

    Running this script throws a couple of errors. Running the same script on 2 of my servers displays the session variable, 'Sendy' correctly. Below is the gist of this error when running this script on your server:

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

    I checked your phpinfo and found that session.save_path has no value:

    All my other servers, local or live, have defined values for session.save_path.

    Please verify with GoDaddy that session variables are working correctly on your server.

    Thanks.

    Ben

  • Awesome, thanks! I'll give them a call today.

  • Ben, You were 100% right. THANK YOU for your efforts here.

    If anybody else has this issue, he is what I had to do to setup Sendy up and running on a GoDaddy Linux, shared hosted server:

    1 - As stated above, in the Sendy .htaccess file, just under the existing mod_rewrite directives, I had to add this (where "sendy" is the name of the directory your Sendy is installed in): RewriteBase /sendy

    2- Once Ben clued me in that the php session path wasn't set, I had to add a php.ini file to handle that. FTP to the root of your account. In this case the root should be where you FTP account takes you to initially. There are higher levels, but I didn't need to go higher.

    Create a new file called php5.ini and saved it. Note if your account uses php 4, you will name your file simply php.ini.

    I pasted in a generic ini file from this source: http://www.reallylinux.com/docs/php.ini

    Next, find the line that has the session.save setting (~ LN 853). GoDaddy specifically says to make that setting: session.save_path = "/tmp"

    ( source: http://support.godaddy.com/groups/web-hosting/topic/php-sessions/?pc_split_value=2 )

    3 - Once your done, if you want to see the changes immediately, you need to restart your web instance. Follow the directions here: http://support.godaddy.com/help/article/5647/why-isnt-my-phpini-file-taking-effect?pc_split_value=2

    Once I did those 3 steps my existing Sendy app that I copied from the old host came up, and so did the fresh install I did during my testing.

  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support

    Great, thanks for these instructions which may help others in future.

This discussion has been closed.
All Discussions