Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

[Dreamhost] Autoresponder not working / steps included
  • Vote Up0Vote Down wbryantwbryant
    Posts: 2Sendy user

    I've gone through all the discussions already asked on this topic I could and have tried the following troubleshooting steps (in this order):

    1. ensured my cron job was set to every minute (it was not at first)
    2. reset my cron setup
    3. after resetting my cron settings, I discovered I had to run the command manually via the terminal before it would recognize my autoresponder link
    4. reset my time zone in sendy to Pacific time to match my server

    I am not sure exactly where the problem lies although I suspect it may be the cron job on my server, I have double checked it and ran the command manually and it still is not sending when I run it manually. I have sent campaigns successfully, and the subscriber thank you email sends successfully. I am using the sendy subscriber form at https://sendy.wpbryant.com/subscription?f=0DfrZTxT6XaVATpRXTT4YIJxHghtqHb01w3CNXYEv43A7aiQMu8dIxo7a77nEX6Uvgx892slaofLjrPlBWtyBu4A

    Cron setup:

    cron setup

    Sendy setup:

    sendy setup

  • 2 Comments
  • Vote Up0Vote Down BenBen
    Posts: 3,421Sendy support

    Hi,

    reset my cron setup after resetting my cron settings, I discovered I had to run the command manually via the terminal before it would recognize my autoresponder link

    Please do not run the autoresponders.php script manually.

    After you setup the 'per minute' cron job for autoresponders.php, the cron job setup instructions will disappear within 1 minute when you refresh the list page.

    If the cron job instructions does not go away after 1 minute, your cron job isn't running or setup correctly. Please contact your hosting support on why your cron job isn't working.

    Thanks.

    Best regards,
    Ben

  • Vote Up0Vote Down wbryantwbryant
    Posts: 2Sendy user

    Figured it out... Dreamhost panel interface does not allow you to setup a cron job every minute, but it will let you set it up in SSH. This link explains how to do it for those also on dreamhost like me https://dhdjdj.com/dreamhost-cron-job.html

This discussion has been closed.
All Discussions