Skip to content

Autoresponder Not Working.

edited November 21 in Troubleshooting

I just noticed that my autoresponder hasn't been sending emails for a long time. To test this myself, I created a new email address and subscribed to the list. I didn't receive the email that is sent out as soon as someone subscribes.

There is a cron job running for autoresponders. I deleted it and then created it again, but still no luck.

Now I can't find where the Cron jobs are specified in Sendy (I have v5.2.5).

Could you please tell me where this setting is, and also why wouldn't the autoresponder be working?

Thanks,

Steve

Comments

  • BenBen
    edited November 21

    Hi,

    1. Please ensure your cron job for autoresponders.php is set to run every 1 minute (not anything more)
    2. Please ensure that you have ‘Enabled’ your autoresponder email after creating them, they are ‘Disabled’ by default.
    3. Please note that Autoresponder emails only trigger when emails are added via Sendy's subscribe form or the 'subscribe' API (https://sendy.co/api), not emails added via the user interface using CSV or the 'per line method'.

    Now I can't find where the Cron jobs are specified in Sendy (I have v5.2.5).

    To see the cron job setup instructions again, visit https://your_sendy_installation_url/reset-cron and hit the reset button.

    Then inside any lists, click on the 'Autoresponders' button at the top right and you'll be shown the cron job setup instructions:

    Thanks.

    Best regards,
    Ben

  • edited November 21

    Hi Ben,

    Thank you so much! The Cron job was set to 2 minutes. I set it to 1 minute and it all started working again.

    Thank you again.

    Regards,

    Steve

This discussion has been closed.