Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

  • Ben November 2012
  • Jay November 2012
Emails not getting through?
  • Vote Up0Vote Down JayJay
    Posts: 15Sendy user
    I upgraded to version 1.1.0 yesterday and sent a campaign to my main list (18k subscribers) last night. It seemed to go much quicker, but I'm not sure all of the emails made it through. I've checked 6 addresses that are subscribed to the list and only one of them have come through. I also checked trash and spam, but nothing.

    Has anyone else seen something like this? Thoughts?

    Thanks in advance.

    Update: I just checked the SES Management console and it says only 2,312 were sent....
  • 13 Comments
  • Vote Up0Vote Down JayJay
    Posts: 15Sendy user
    Moved this comment up there ^
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    About 15 hours ago, SES experienced some problems:

    image

    This may have been the cause.
  • Vote Up0Vote Down JayJay
    Posts: 15Sendy user
    My campaign would have been sent about 6 hours after that last entry.
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    I'm not sure if the issue from SES still persist after 6 hours. Are you sending via cron?
  • Vote Up0Vote Down JayJay
    Posts: 15Sendy user
    Yes, I am sending via cron.

    It looks like the SES problems above related to duplication and latency, not failure.
  • Vote Up0Vote Down JayJay
    Posts: 15Sendy user
    Just found that there are 1,187 active subscribers in the list that didn't have "last_campaign" updated. It seems that almost 16,000 emails didn't make it to SES, though.
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    Can you check the 'queue' table your the database and see if the emails are there?
  • Vote Up0Vote Down JayJay
    Posts: 15Sendy user
    It is empty.
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    Possible to get the error log for the period when you sent your campaign?
  • Vote Up0Vote Down JayJay
    Posts: 15Sendy user
    Each of these are repeated thousands of times. Especially the last one:

    [Thu Nov 15 22:04:36 2012] [error] [client 174.50.251.97] PHP Notice: Undefined index: link_name in /var/www/vhosts/domain.com/httpdocs/s/includes/dashboard/main.php on line 36, referer: http://domain.com/s/

    [Thu Nov 15 22:04:39 2012] [error] [client 174.50.251.97] PHP Notice: Undefined offset: 16 in /var/www/vhosts/domain.com/httpdocs/s/report.php on line 657, referer: http://domain.com/s/app?i=1
    [Thu Nov 15 22:04:39 2012] [error] [client 174.50.251.97] PHP Notice: Undefined offset: 1 in /var/www/vhosts/domain.com/httpdocs/s/report.php on line 658, referer: http://domain.com/s/app?i=1

    [Thu Nov 15 22:04:49 2012] [error] [client 174.50.251.97] PHP Notice: Undefined index: link_name in /var/www/vhosts/domain.com/httpdocs/s/includes/dashboard/main.php on line 36, referer: http://domain.com/s/

    [Thu Nov 15 22:40:37 2012] [error] [client 72.47.248.35] PHP Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /var/www/vhosts/domain.com/httpdocs/s/scheduled.php on line 203
    [Thu Nov 15 22:40:37 2012] [error] [client 72.47.248.35] PHP Notice: Undefined variable: to_send in /var/www/vhosts/domain.com/httpdocs/s/scheduled.php on line 502
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    Thanks. Are you running PHP in safe mode?
  • Vote Up0Vote Down JayJay
    Posts: 15Sendy user
    I saw that, so I've turned it off.
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support
    That should do it.
This discussion has been closed.
All Discussions