Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Translation Problem on Amazon EC2
  • Hi, we just bought Sendy and we found this software as very nice. Unlucky, we have a big problem because we can't see the translation working. We uploaded the language .po files, setted up the accounts properly, but we can't see the result. It always shows up in English.

    We tried to follow the Ubuntu guide to generate our own locale ( it_IT ), but there is no package called locale-gen or similar, on the Amazon Linux AMI release 2013.09 .

    How could we see the translation in our own language ?

    Thank you in advance.

  • 12 Comments
  • Hi, we just bought Sendy and we found this software as very nice. Unlucky, we have a big problem because we can't see the translation working. We uploaded the language .po files, setted up the accounts properly, but we can't see the result. It always shows up in English.

    We tried to follow the Ubuntu guide to generate our own locale ( it_IT ), but there is no package called locale-gen or similar, on the Amazon Linux AMI release 2013.09 .

    How could we see the translation in our own language ?

    Thank you in advance.

  • Vote Up0Vote Down BenBen
    Posts: 3,489Sendy support

    Hi,

    Please see '[Users on Ubuntu] Sendy's interface not changed to the language I selected' on http://sendy.co/troubleshooting

    Thanks.

    Best regards,
    Ben

  • Hello, unlucky we do have this problem running the standard Linux Ami. We don't see any error on the server log. We can't and don't want to change our Linux Ami, just willing to make things works perfectly :)

    We don't know if we have to make our locales using locale-gen, because it seems that is a ubunty-only command. So the ubuntu how-to just doesn't work for us.

    Could you help us to resolve our issue ?

    Best regards, Daniele

  • Vote Up0Vote Down BenBen
    Posts: 3,489Sendy support

    I have installed a lot of LAMP stack on EC2 Linux AMI for other users without problems. Can you show me a screenshot of where you uploaded your language file so I can see if there's anything wrong?

    Thank you.

    Best regards,
    Ben

  • That is our directory structure:

    http://picpaste.com/pics/tree-hpc0G9Mj.1394993211.png

    Thank you in advance! Daniele

  • Vote Up0Vote Down BenBen
    Posts: 3,489Sendy support

    Thanks Daniele, looks fine to me. Ok this may be a stupid question but you did set your language to the one you translated in Sendy's settings right? :)

  • There are no stupid question, only unasked one :) Yes, we switched the language for the main account, and for the brand accounts, but it doesn't work at all.

  • Vote Up0Vote Down BenBen
    Posts: 3,489Sendy support

    Thanks for clarifying that. :) Can you send me your language file in a zip so I can try it on my installation to see if there's any issues with the files? Thanks.

  • Vote Up0Vote Down BenBen
    Posts: 3,489Sendy support

    Thanks. Can you please upload this language file to your server replacing the old one then try setting the language to Italian again ? http://d.pr/f/DfWk

  • It works ! Thank you !

    What was wrong ? Thank you again .

    Daniele

  • Vote Up0Vote Down BenBen
    Posts: 3,489Sendy support

    You're welcome! I opened the .po file in Poedit and hit 'Save'. Then it worked, not sure what was wrong either. But glad that it's working for you now. :)

This discussion has been closed.
All Discussions