Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Installation - Forwards User to 1and1 Affiliate Link
  • Had I paid more attention to what I was doing, this wouldn't have happened to me, but it's late at night and I've been working for like 16 hours. 99% of people won't have this problem, but I am reposting it to save those select few who will be affected by this problem because it took some research to figure out what was happening.

    So, I uploaded the software, then configured my database settings in the config.php file. (I should have read the whole config.php file, and you'll see why.) I skipped the settings for domain name and so forth (and the quick start information does not say to change anything about domain, recommend adding a little more meat to the instructions), and it was left as yourdomain.com/...

    When I browsed to my installation, it automatically sent me to ( http://www.1and1.com/?affiliate_id=322774 ). I thought my web server had been hacked, but I found that all of my domains were working how they were supposed to. Perplexed, I started searching Google for the above link to see if I could figure out how it was happening in reverse.

    Basically, yourdomain.com points to the above referral link. Then, it clicked; every script in the world that uses yourdomain.com as an example/placeholder is giving these people affiliate clicks. It also meant that my installation was caught in the affiliate scheme.

    Anyway, the verbose instructions:

    In config.php, change these values:

    //==================================================================================//
    // Configuration
    //==================================================================================//

    Step 1: Leave this alone unless you have reason to change it:

    //domain of cookie (ignore this if unsure)
    define('COOKIE_DOMAIN', '');

    Step 2: Change this to an email you own:

    //this email is needed when confirming Amazon SNS subscription.
    //Amazon SNS is required to track bounces.
    define('EMAIL', 'youremail@yourpage.foo');

    Step 3: Change this to the path of your Sendy installation:

    //path to your Sendy installation (without the trailing slash)
    define('APP_PATH', 'http://www.yourpage.foo);

    Step 4: Change these to the settings for your database:

    //database connection credentials
    $dbHost = 'localhost'; //mySQL Hostname
    $dbUser = 'user'; //mySQL Username
    $dbPass = 'pass'; //mySQL Password
    $dbName = 'db'; //mySQL Database Name

    And that's it.

    Granted, this is a no-brainer problem and would probably be avoided by everyone but me (lol), but when your eyes have glazed over and you've been staring at code for hours and hours, sometimes the full instructions will help figure out bizarre problems. Anyway, hope it helps someone.
  • 2 Comments
  • Vote Up0Vote Down BenBen
    Posts: 3,489Sendy support
    @latenitebooks thanks so much for taking the time to post this. Will use another URL for the placeholder instead of yourdomain.com
  • No problem, Ben. If it hadn't been an affiliate domain, I wouldn't have had any problems because the server error would've shown me something useful. But, since it was an affiliate forwarder, it skipped my website and did all of those crazy things. :)
This discussion has been closed.
All Discussions