Get answers quicker by searching

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

I bungled the upgrade. Now what?
  • Ben,

    I bungled the upgrade and mistakenly over wrote the existing Includes folder with version 1.1.4. Now it's taking me to the installation screen and despite entering all of the correct credentials, I can't get past it. It just refreshes and takes me back to the same page asking me to enter the same credentials. Obviously, Sendy is already installed.

    What do I need to do to correct this?

    Do I need to delete everything and install from scratch and if so, is there a way to pull in the prior campaigns, brands and lists since they're still in the DB?

    Sorry for the inconvenience. This is a bonehead mistake on my part.

  • 8 Comments
  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support

    Hi @vincentpolisi,

    First of all, don't worry, your data is intact in your database.

    Do you mean you've verified that the settings in /includes/config.php file is correct but it keeps taking you to the installation page?

    Sorry for the inconvenience. This is a bonehead mistake on my part.

    Don't worry about it, we're all human. :)

    Thanks.

    Ben

  • Ben, yes. Settings are verified in /includes/config.php but it keeps taking me to the install page http://cloud.vincentpolisi.com/Screenshot_1_2_13_8_06_AM.png

    When I input the correct credentials on this page, it just refreshes the page and clears the credentials.

    How do I fix this?

  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support

    Hi @vincentpolisi

    Can you check if you have mysqli extension installed on PHP?

    Taken from phpinfo:

    image

    Thanks.

    Ben

  • Here's what I show: image

  • What happens if I delete everything and do a clean install? Will it re-connect prior brands, lists, campaigns from the database automatically?

  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support

    Hi @vincentpolisi,

    As long as you don't delete the contents of your database or the database itself, your brands, lists, campaigns, reports etc will be intact.

    Also make sure to backup the /uploads/ folder if you've ever uploaded any images inside.

    Thanks.

    Ben

  • Ben, really need some help here, please. I deleted everything in the root directory and did a clean install, again with proper credentials. Instead of taking me to the install page, it took me to the login screen but wouldn't allow me to login with proper credentials. I took a look at the password in phpMyAdmin and it had been changed to a randomly generated password. I manually changed it back in phpMyAdmin. No joy. I then changed it and MD5'ed it. Took 3 different attempts to get it to stick in the DB instead of reverting to a randomly generated password. Still wouldn't let me login. I started digging around the database and it appeared that there may have been a duplicate login ID under the login table (though I later found this to be incorrect). I deleted everything but the main login of ID 1. Still nothing (I went back in and manually created them again but I am guessing something is incorrect). I then went to the login screen for my Sendy installation. Asked it to reset password. Entered the new Sendy generated password and I could get in. The only problem is, nothing appears even though it's connected to the database. No brands, no lists, no reports. The settings screen is missing fields for some reason (doesn't show AWS credentials, Sendy license or API key) and doesn't include the requisite info despite the fact that I've sent hundreds of thousands of emails with this DB. And, it's somehow locked in a send from email address (which is one from one of the Brands created and it won't allow me to change it. I am guessing this has to do with the logins I deleted. I manually recreated them based off the Apps field

    image

    I then created a completely new DB and changed the config.php file to use it. I can login there fine and it shows the settings page but obviously it's a blank DB.

    image

    So, I need to either fix the DB for the initial install that has all of the brands, lists, campaigns, reports, etc., so it properly displays in Sendy OR I need to be able to export that information into the new clean DB and I need to do this as soon as possible as I have a campaign that's supposed to go out in 7:30AM (GMT-5) and it's presently 2:30AM (GMT-5)

    Since this is a relatively new install, I'm fine exporting the lists and everything into the new DB if that's easier. The key thing is that I need to be sure not to export/import and send information to people that have unsubscribed.

    Can you tell me what I need to do?

  • Vote Up0Vote Down BenBen
    Posts: 3,484Sendy support

    Hi Vincent,

    I fixed it.

    I checked your database and found that the login relationships with the brands are quite messed up.

    I've cleared it up.

    Thanks.

    Ben

This discussion has been closed.
All Discussions